구축환경
GNS3 - (https://www.gns3.com/software/download)
VLAN
[VLAN]
물리적인 랜 구성과 상관없이 논리적으로 구성하는 것 (가상랜)
virtual
[구성된 IP 삭제 하는 방법]
X-SW>enable
X-SW#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
X-SW(config)#int vlan
% Incomplete command.
X-SW(config)#int vlan 1
X-SW(config-if)#no ip address
[Switch 1]
Switch>enable
Switch#show vlan
[요약한 정보 볼 때]
Switch#show vlan brief
결과
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
[VLAN 생성]
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name Marketing
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name Information
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name Development (이 스위치에 연결되어있지 않더라도 연결해둬야함)
show vlan 으로 확인하면 아직 연결된 포트가 없다.
*명령어를 잘 모를 때 대략적인 명령어 입력 후 ? 를 넣으면 명령어 목록을 보여준다.
*그냥 물음표를 해도 명령어 목록을 보여준다.
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface Fa0/2
Switch(config-if)#switchport mode ?
access Set trunking mode to ACCESS unconditionally (디바이스와 연결된 스위치)
dynamic Set trunking mode to dynamically negotiate access or trunk mode (보안상 사용하기 위험함)
trunk Set trunking mode to TRUNK unconditionally (라우터와 연결된 스위치)
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface fa0/3
Switch(config-if)#switch mode access
Switch(config-if)#switchport access vlan 20
[Fa 0/1번 포트와 X-SW를 연결할 때]
trunking이란? vlan들의 통로를 만들어 주는 것
Switch(config-if)#exit
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk
결과
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24, Gig0/1, Gig0/2
10 Marketing active Fa0/2
20 Information active Fa0/3
30 Development active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN의 전용 통로를 만드는 것이기 때문에 1번 포트가 사라져있다.
Switch#show interface trunk (trunking 정보보기)
결과
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-1005
Port Vlans allowed and active in management domain
Fa0/1 1,10,20,30
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,10,20,30
[중간 스위치 X-SW]
X-SW>enable
X-SW#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
X-SW(config)#vlan 10
X-SW(config-vlan)#name Marketing
X-SW(config-vlan)#exit
X-SW(config)#vlan 20
X-SW(config-vlan)#name Information
X-SW(config-vlan)#exit
X-SW(config)#vlan 30
X-SW(config-vlan)#name Development
X-SW(config-vlan)#exit
트렁킹 설정
X-SW(config-if)#switchport mode trunk
X-SW(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
X-SW(config-if)#exit
X-SW(config)#int fa0/5
X-SW(config-if)#switchport mode trunk
X-SW(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up
Trunk, Access 연결하기
X-SW#en
X-SW#conf t
Enter configuration commands, one per line. End with CNTL/Z.
X-SW(config)#vlan 10
X-SW(config-vlan)#name Marketing
X-SW(config-vlan)#exit
X-SW(config)#vlan 20
X-SW(config-vlan)#name Information
X-SW(config-vlan)#exit
X-SW(config)#vlan 30
X-SW(config-vlan)#name Development
X-SW(config-vlan)#exit
X-SW(config)#int fa0/5
X-SW(config-if)#switchport mode trunk
X-SW(config-if)#exit
X-SW(config)#int fa0/4
X-SW(config-if)#switchport mode trunk
X-SW(config-if)#exit
X-SW(config)#int fa0/2
X-SW(config-if)#switchport mode access
X-SW(config-if)#switchport access vlan 10
X-SW(config-if)#exit
X-SW(config)#int fa0/3
X-SW(config-if)#switchport mode access
X-SW(config-if)#switchport access vlan 30
X-SW(config-if)#exit
X-SW(config)#show vlan
범위로 인터페이스 설정하는 방법(일괄 설정)
- range명령어 사용
--------------------------------------------------------------------------------------------------
지금까지는 동일VLAN과는 통신이 되지만 다른VLAN과는 통신이 안되는 상태이다.
그래서 다른 VLAN끼리도 통신이 되려면 3계층 장비의 설정이 추가적으로 필요하다.
*sub-interface: 쪼개는 개념
[Gig 0/0]
X>en
Password:
X#conf t
Enter configuration commands, one per line. End with CNTL/Z.
X(config)#int gi0/0
X(config-if)#no ip address
X(config-if)#no shutdown
---sub-interface로 쪼개기--------
X(config)#int gi0/0.?
<0-4294967295> GigabitEthernet interface number
X(config)#int gi0/0.10
X(config-subif)#
X(config-subif)#encapsulation dot1q 10
X(config-subif)#ip address 192.168.10.1 255.255.255.192
IEEE: Institute of Electrical and Electronics Engineers: 국제전기전자엔지니어협회
[20번 VLAN]
X(config-subif)#int gi0/0.20
X(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up
X(config-subif)#encapsulation dot1q 20
X(config-subif)#ip address 192.168.10.120 255.255.255.192
[30번 VLAN]
X(config-subif)#int gi0/0.30
X(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up
X(config-subif)#encapsulation dot1q 30
X(config-subif)#ip address 192.168.10.200 255.255.255.192
*게이트웨이 값이 다르면 통신이 안된다.
각 PC마다 게이트웨이 VLAN에 따라 설정하기
MAC 주소: 물리적주소
'정보보안실무 > 네트워크' 카테고리의 다른 글
Net.06 RIP <-> EIGRP 재분배 (0) | 2023.04.16 |
---|---|
Net.05 GNS3 EIGRP 구축 및 설정 (0) | 2023.04.16 |
Net.04 GNS3 RIP 구축 및 설정 (0) | 2023.04.16 |
Net.03 MAC, IP, Port와 서브넷팅 (OSI 7 Layer) (0) | 2023.04.16 |
Net.01 GNS3 구축 및 서브넷팅 (0) | 2023.04.16 |